Autoupgrade no term...
 
Avisos
Vaciar todo

Autoupgrade no termina de verificar requisitos necesarios

1 Respuestas
1 Usuarios
0 Me gustas
2 Visitas
Francisco GP
Respuestas: 18
Admin
Topic starter
(@iguannaweb)
Miembro
Registrado: hace 3 años

Si quieres actualizar a ultima versión v1.7 o v8 el módulo autoupgrade no te lo pone fácil y el último requisito de session no termina de verificar. El patch ya está pero como no ha salido la versión nueva, te lo dejo aquí.

    public function isPhpSessionsValid()
    {
       /* if (!class_exists(ConfigurationTest::class)) {
            return true;
        }

        return ConfigurationTest::test_sessions();*/
        return in_array(session_status(), [PHP_SESSION_ACTIVE, PHP_SESSION_NONE], true);
    }

   

Esta función deberías modificarla en classes/UpgradeSelfCheck.php

 

Etiquetas del debate